In short
- CVE-2020-36655 is a HIGH (CVSS 8.8) vulnerability affecting yiisoft/yii2-gii, gii (yiiframework).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.7% of all vulnerabilities.
- Fix: update to 2.2.2 or later.
Description
Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field. The attacker can embed arbitrary PHP code into the model file.
NVD description
Yii Yii2 Gii before 2.2.2 allows remote attackers to execute arbitrary code via the Generator.php messageCategory field. The attacker can embed arbitrary PHP code into the model file.
More vulnerabilities in yiisoft/yii2-gii
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free