| Package | Affected versions | Patched versions |
|---|---|---|
| wordpress | ≥ 3.7, < 3.7.34≥ 3.8, < 3.8.34≥ 3.9, < 3.9.32≥ 4.0, < 4.0.31≥ 4.1, < 4.1.31≥ 4.2, < 4.2.28≥ 4.3, < 4.3.24≥ 4.4, < 4.4.23≥ 4.5, < 4.5.22≥ 4.6, < 4.6.19≥ 4.7, < 4.7.18≥ 4.8, < 4.8.14≥ 4.9, < 4.9.15≥ 5.0, < 5.0.10≥ 5.1, < 5.1.6≥ 5.2, < 5.2.7≥ 5.3.0, < 5.3.4≥ 5.4, < 5.4.2 | 3.7.343.8.343.9.324.0.314.1.314.2.284.3.244.4.234.5.224.6.194.7.184.8.144.9.155.0.105.1.65.2.75.3.45.4.2 |
In affected versions of WordPress, users with low privileges (like contributors and authors) can use the embed block in a certain way to inject unfiltered HTML in the block editor. When affected posts are viewed by a higher privileged user, this could lead to script execution in the editor/wp-admin. This has been patched in version 5.4.2, along with all the previously affected versions via a minor release (5.3.4, 5.2.7, 5.1.6, 5.0.10, 4.9.15, 4.8.14, 4.7.18, 4.6.19, 4.5.22, 4.4.23, 4.3.24, 4.2.28, 4.1.31, 4.0.31, 3.9.32, 3.8.34, 3.7.34).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free