In short
- CVE-2020-7597 is a HIGH (CVSS 8.8) vulnerability affecting codecov (codecov), codecov.
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 87.1% of all vulnerabilities.
- Fix: update to 3.6.5 or later.
| Package | Affected versions | Patched versions |
|---|
| codecov | < 3.6.5
| 3.6.5
|
| codecov npm | < 3.6.5
| 3.6.5
|
Description
codecov-node npm module before 3.6.5 allows remote attackers to execute arbitrary commands.The value provided as part of the gcov-root argument is executed by the exec function within lib/codecov.js. This vulnerability exists due to an incomplete fix of CVE-2020-7596.
NVD description
codecov-node npm module before 3.6.5 allows remote attackers to execute arbitrary commands.The value provided as part of the gcov-root argument is executed by the exec function within lib/codecov.js. This vulnerability exists due to an incomplete fix of CVE-2020-7596.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free