In short
- CVE-2020-7600 is a MEDIUM (CVSS 5.3) vulnerability affecting querymen (querymen project), querymen.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.2% of all vulnerabilities.
- Fix: update to 2.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| querymen | < 2.1.4
| 2.1.4
|
| querymen npm | < 2.1.4
| 2.1.4
|
Description
querymen prior to 2.1.4 allows modification of object properties. The parameters of exported function handler(type, name, fn) can be controlled by users without any sanitization. This could be abused for Prototype Pollution attacks.
NVD description
querymen prior to 2.1.4 allows modification of object properties. The parameters of exported function handler(type, name, fn) can be controlled by users without any sanitization. This could be abused for Prototype Pollution attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free