In short
- CVE-2020-7609 is a CRITICAL (CVSS 9.8) vulnerability affecting node-rules (node-rules project), node-rules.
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.9% of all vulnerabilities.
- Fix: update to 5.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| node-rules | ≥ 3.0.0, < 5.0.0
| 5.0.0
|
| node-rules npm | ≥ 3.0.0, < 5.0.0
| 5.0.0
|
Description
node-rules including 3.0.0 and prior to 5.0.0 allows injection of arbitrary commands. The argument rules of function "fromJSON()" can be controlled by users without any sanitization.
NVD description
node-rules including 3.0.0 and prior to 5.0.0 allows injection of arbitrary commands. The argument rules of function "fromJSON()" can be controlled by users without any sanitization.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free