In short
- CVE-2020-7658 is a MEDIUM (CVSS 6.1) vulnerability affecting meinheld, meinheld (meinheld).
- Chance of exploitation in the next 30 days (EPSS): 0.69%, higher than 52.9% of all vulnerabilities.
- Fix: update to 1.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| meinheld PyPI | < 1.0.2
| 1.0.2
|
| meinheld | < 1.0.2
| 1.0.2
|
Description
meinheld prior to 1.0.2 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing.
NVD description
meinheld prior to 1.0.2 is vulnerable to HTTP Request Smuggling. HTTP pipelining issues and request smuggling attacks might be possible due to incorrect Content-Length and Transfer encoding header parsing.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free