In short
- CVE-2020-7676 is a MEDIUM (CVSS 5.4) vulnerability affecting angularjs (angularjs), angular.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 80.0% of all vulnerabilities.
- Fix: update to 1.8.0 or later.
| Package | Affected versions | Patched versions |
|---|
| angularjs | < 1.8.0
| 1.8.0
|
| angular npm | < 1.8.0
| 1.8.0
|
Description
angular.js prior to 1.8.0 allows cross site scripting. The regex-based input HTML replacement may turn sanitized code into unsanitized one. Wrapping <option> elements in <select> ones changes parsing behavior, leading to possibly unsanitizing code.
NVD description
angular.js prior to 1.8.0 allows cross site scripting. The regex-based input HTML replacement may turn sanitized code into unsanitized one. Wrapping "<option>" elements in "<select>" ones changes parsing behavior, leading to possibly unsanitizing code.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free