In short
- CVE-2020-7693 is a MEDIUM (CVSS 5.3) vulnerability affecting sockjs (sockjs project), sockjs.
- Chance of exploitation in the next 30 days (EPSS): 5.0%, higher than 92.2% of all vulnerabilities.
- Fix: update to 0.3.20 or later.
| Package | Affected versions | Patched versions |
|---|
| sockjs | < 0.3.20
| 0.3.20
|
| sockjs npm | < 0.3.20
| 0.3.20
|
Description
Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.
NVD description
Incorrect handling of Upgrade header with the value websocket leads in crashing of containers hosting sockjs apps. This affects the package sockjs before 0.3.20.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free