In short
- CVE-2020-7743 is a HIGH (CVSS 7.3) vulnerability affecting mathjs (mathjs), mathjs.
- Chance of exploitation in the next 30 days (EPSS): 3.9%, higher than 90.4% of all vulnerabilities.
- Fix: update to 7.5.1 or later.
| Package | Affected versions | Patched versions |
|---|
| mathjs | < 7.5.1
| 7.5.1
|
| mathjs npm | < 7.5.1
| 7.5.1
|
Description
The package mathjs before 7.5.1 are vulnerable to Prototype Pollution via the deepExtend function that runs upon configuration updates.
NVD description
The package mathjs before 7.5.1 are vulnerable to Prototype Pollution via the deepExtend function that runs upon configuration updates.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free