In short
- CVE-2020-7748 is a HIGH (CVSS 8.1) vulnerability affecting ts.ed (ts.ed project), @tsed/core.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.6% of all vulnerabilities.
- Fix: update to 5.65.7 or later.
| Package | Affected versions | Patched versions |
|---|
| ts.ed | < 5.65.7
| 5.65.7
|
| @tsed/core npm | < 5.65.7
| 5.65.7
|
Description
This affects the package @tsed/core before 5.65.7. This vulnerability relates to the deepExtend function which is used as part of the utils directory. Depending on if user input is provided, an attacker can overwrite and pollute the object prototype of a program.
NVD description
This affects the package @tsed/core before 5.65.7. This vulnerability relates to the deepExtend function which is used as part of the utils directory. Depending on if user input is provided, an attacker can overwrite and pollute the object prototype of a program.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free