In short
- CVE-2020-7755 is a HIGH (CVSS 7.5) vulnerability affecting dat.gui (dat.gui project), dat.gui.
- Chance of exploitation in the next 30 days (EPSS): 2.1%, higher than 81.8% of all vulnerabilities.
- Fix: update to 0.7.8 or later.
| Package | Affected versions | Patched versions |
|---|
| dat.gui | < 0.7.8
| 0.7.8
|
| dat.gui npm | ≤ 0.7.7
| No fix yet |
Description
All versions of package dat.gui are vulnerable to Regular Expression Denial of Service (ReDoS) via specifically crafted rgb and rgba values.
NVD description
All versions of package dat.gui are vulnerable to Regular Expression Denial of Service (ReDoS) via specifically crafted rgb and rgba values.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free