In short
- CVE-2020-7965 is a HIGH (CVSS 8.8) vulnerability affecting webargs, webargs (webargs project).
- Chance of exploitation in the next 30 days (EPSS): 0.61%, higher than 49.2% of all vulnerabilities.
- Fix: update to 5.5.3, 6.0.0b4 or later.
| Package | Affected versions | Patched versions |
|---|
| webargs PyPI | ≥ 5.0.0, < 5.5.3≥ 6.0.0b1, < 6.0.0b4
| 5.5.36.0.0b4
|
| webargs | ≥ 5.0.0, ≤ 5.5.2
| No fix yet |
Description
flaskparser.py in Webargs 5.x through 5.5.2 doesn't check that the Content-Type header is application/json when receiving JSON input. If the request body is valid JSON, it will accept it even if the content type is application/x-www-form-urlencoded. This allows for JSON POST requests to be made across domains, leading to CSRF.
NVD description
flaskparser.py in Webargs 5.x through 5.5.2 doesn't check that the Content-Type header is application/json when receiving JSON input. If the request body is valid JSON, it will accept it even if the content type is application/x-www-form-urlencoded. This allows for JSON POST requests to be made across domains, leading to CSRF.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free