In short
- CVE-2020-7981 is a CRITICAL (CVSS 9.8) vulnerability affecting geocoder, geocoder (rubygeocoder).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.1% of all vulnerabilities.
- Fix: update to 1.6.1 or later.
| Package | Affected versions | Patched versions |
|---|
| geocoder RubyGems | < 1.6.1
| 1.6.1
|
| geocoder | < 1.6.1
| 1.6.1
|
Description
sql.rb in Geocoder before 1.6.1 allows Boolean-based SQL injection when within_bounding_box is used in conjunction with untrusted sw_lat, sw_lng, ne_lat, or ne_lng data.
NVD description
sql.rb in Geocoder before 1.6.1 allows Boolean-based SQL injection when within_bounding_box is used in conjunction with untrusted sw_lat, sw_lng, ne_lat, or ne_lng data.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free