In short
- CVE-2020-8127 is a MEDIUM (CVSS 6.1) vulnerability affecting reveal.js (revealjs), reveal.js.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.2% of all vulnerabilities.
- Fix: update to 3.9.2 or later.
| Package | Affected versions | Patched versions |
|---|
| reveal.js | ≤ 3.9.1
| No fix yet |
| reveal.js npm | < 3.9.2
| 3.9.2
|
Description
Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform cross-site scripting attacks.
NVD description
Insufficient validation in cross-origin communication (postMessage) in reveal.js version 3.9.1 and earlier allow attackers to perform cross-site scripting attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free