In short
- CVE-2020-8130 is a MEDIUM (CVSS 6.4) vulnerability affecting rake, rake (ruby-lang).
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 71.7% of all vulnerabilities.
- Fix: update to 12.3.3 or later.
| Package | Affected versions | Patched versions |
|---|
| rake RubyGems | < 12.3.3
| 12.3.3
|
| rake | < 12.3.3
| 12.3.3
|
Description
There is an OS command injection vulnerability in Ruby Rake before 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character |.
NVD description
There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character `|`.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free