In short
- CVE-2020-8149 is a CRITICAL (CVSS 9.8) vulnerability affecting logkitty (logkitty project), logkitty.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 81.0% of all vulnerabilities.
- Fix: update to 0.7.1 or later.
| Package | Affected versions | Patched versions |
|---|
| logkitty | < 0.7.1
| 0.7.1
|
| logkitty npm | < 0.7.1
| 0.7.1
|
Description
Lack of output sanitization allowed an attack to execute arbitrary shell commands via the logkitty npm package before version 0.7.1.
NVD description
Lack of output sanitization allowed an attack to execute arbitrary shell commands via the logkitty npm package before version 0.7.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free