In short
- CVE-2020-8161 is a HIGH (CVSS 8.6) vulnerability affecting rack, rack (rack project).
- Chance of exploitation in the next 30 days (EPSS): 3.4%, higher than 88.7% of all vulnerabilities.
- Fix: update to 2.1.3, 2.2.0 or later.
| Package | Affected versions | Patched versions |
|---|
| rack RubyGems | < 2.1.3
| 2.1.3
|
| rack | < 2.2.0
| 2.2.0
|
Description
A directory traversal vulnerability exists in rack < 2.2.0 that allows an attacker perform directory traversal vulnerability in the Rack::Directory app that is bundled with Rack which could result in information disclosure.
NVD description
A directory traversal vulnerability exists in rack < 2.2.0 that allows an attacker perform directory traversal vulnerability in the Rack::Directory app that is bundled with Rack which could result in information disclosure.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free