In short
- CVE-2020-8192 is a MEDIUM (CVSS 6.5) vulnerability affecting fastify (fastify), fastify.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.1% of all vulnerabilities.
- Fix: update to 2.15.1 or later.
| Package | Affected versions | Patched versions |
|---|
| fastify | = 2.14.1= 3.0.0
| No fix yet |
| fastify npm | < 2.15.1
| 2.15.1
|
Description
A denial of service vulnerability exists in Fastify v2.14.1 and v3.0.0-rc.4 that allows a malicious user to trigger resource exhaustion (when the allErrors option is used) with specially crafted schemas.
NVD description
A denial of service vulnerability exists in Fastify v2.14.1 and v3.0.0-rc.4 that allows a malicious user to trigger resource exhaustion (when the allErrors option is used) with specially crafted schemas.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free