In short
- CVE-2020-8214 is a HIGH (CVSS 7.5) vulnerability affecting servey (servey project), servey.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.7% of all vulnerabilities.
- Fix: update to 3.1.0, 3.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| servey | ≥ 2.2.0, < 3.1.0
| 3.1.0
|
| servey npm | < 3.3.2
| 3.3.2
|
Description
A path traversal vulnerability in servey versions prior to 3.3.2 allows an attacker to read content of any arbitrary file.
NVD description
A path traversal vulnerability in servey version < 3 allows an attacker to read content of any arbitrary file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free