In short
- CVE-2020-8215 is a HIGH (CVSS 8.8) vulnerability affecting canvas (automattic), canvas.
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.5% of all vulnerabilities.
- Fix: update to 1.6.11 or later.
| Package | Affected versions | Patched versions |
|---|
| canvas | ≤ 1.6.9
| No fix yet |
| canvas npm | < 1.6.11
| 1.6.11
|
Description
A buffer overflow is present in canvas versions before 1.6.11, which could lead to a Denial of Service or execution of arbitrary code when it processes a user-provided image.
NVD description
A buffer overflow is present in canvas version <= 1.6.9, which could lead to a Denial of Service or execution of arbitrary code when it processes a user-provided image.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free