In short
- CVE-2021-20183 is a MEDIUM (CVSS 5.4) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.83%, higher than 57.5% of all vulnerabilities.
- Fix: update to 4.0.0-beta, 3.10.1 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.10, < 4.0.0-beta
| 4.0.0-beta
|
| moodle | < 3.10.1
| 3.10.1
|
Description
It was found in Moodle before version 4.0.0-beta that some search inputs were vulnerable to reflected Cross-site Scripting (XSS) due to insufficient escaping of search queries.
NVD description
It was found in Moodle before version 3.10.1 that some search inputs were vulnerable to reflected XSS due to insufficient escaping of search queries.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free