In short
- CVE-2021-20184 is a MEDIUM (CVSS 4.3) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 0.73%, higher than 54.2% of all vulnerabilities.
- Fix: update to 3.10.1, 3.8.7, 3.9.4 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.10, < 3.10.1≥ 3.8, < 3.8.7≥ 3.9, < 3.9.4
| 3.10.13.8.73.9.4
|
| moodle | ≥ 3.10.0, < 3.10.1≥ 3.9.0, < 3.9.4< 3.8.7
| 3.10.13.9.43.8.7
|
Description
It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.
NVD description
It was found in Moodle before version 3.10.1, 3.9.4 and 3.8.7 that a insufficient capability checks in some grade related web services meant students were able to view other students grades.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free