In short
- CVE-2021-20195 is a CRITICAL (CVSS 9.6) vulnerability affecting org.keycloak:keycloak-core, keycloak (redhat).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 69.4% of all vulnerabilities.
- Fix: update to 13.0.0, 12.0.3 or later.
Description
A flaw was found in keycloak in versions before 13.0.0. A Self Stored XSS attack vector escalating to a complete account takeover is possible due to user-supplied data fields not being properly encoded and Javascript code being used to process the data. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
NVD description
A flaw was found in keycloak in versions before 13.0.0. A Self Stored XSS attack vector escalating to a complete account takeover is possible due to user-supplied data fields not being properly encoded and Javascript code being used to process the data. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
More vulnerabilities in org.keycloak:keycloak-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free