In short
- CVE-2021-21241 is a HIGH (CVSS 7.4) vulnerability affecting flask-security-too, flask-security-too (flask-security-too project).
- Chance of exploitation in the next 30 days (EPSS): 0.93%, higher than 60.7% of all vulnerabilities.
- Fix: update to 3.4.5 or later.
Description
Issue
The /login and /change endpoints can return the authenticated user's authentication token in response to a GET request. Since GET requests aren't protected with a CSRF token, this could lead to a malicious 3rd party site acquiring the authentication token.
Patches
Version 3.4.5 and soon to be released 4.0.0 are patched.
Workarounds
If you aren't using authentication tokens - you can set the SECURITY_TOKEN_MAX_AGE to "0" (seconds) which should make the token unusable.
References
None
NVD description
The Python "Flask-Security-Too" package is used for adding security features to your Flask application. It is an is a independently maintained version of Flask-Security based on the 3.0.0 version of Flask-Security. In Flask-Security-Too from version 3.3.0 and before version 3.4.5, the /login and /change endpoints can return the authenticated user's authentication token in response to a GET request. Since GET requests aren't protected with a CSRF token, this could lead to a malicious 3rd party site acquiring the authentication token. Version 3.4.5 and version 4.0.0 are patched. As a workaround, if you aren't using authentication tokens - you can set the SECURITY_TOKEN_MAX_AGE to "0" (seconds) which should make the token unusable.
More vulnerabilities in flask-security-too
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free