In short
- CVE-2021-21304 is a CRITICAL (CVSS 9.8) vulnerability affecting dynamoose (dynamoosejs), dynamoose.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 80.0% of all vulnerabilities.
- Fix: update to 2.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| dynamoose | ≥ 2.0.0, < 2.7.0
| 2.7.0
|
| dynamoose npm | ≥ 2.0.0, < 2.7.0
| 2.7.0
|
Description
Impact
In Dynamoose versions 2.0.0-2.6.0 there was a prototype pollution vulnerability in the internal utility method lib/utils/object/set.ts. This method is used throughout the codebase for various operations throughout Dynamoose.
We have not seen any evidence of this vulnerability being exploited.
We do not believe this issue impacts v1.x.x since this method was added as part of the v2 rewrite. This vulnerability also impacts v2.x.x beta/alpha versions.
Patches
v2.7.0 includes a patch for this vulnerability.
Workarounds
We are unaware of any workarounds to patch this vulnerability other than upgrading to v2.7.0 or greater.
References
- Patch commit hash: 324c62b4709204955931a187362f8999805b1d8e
For more information
If you have any questions or comments about this advisory:
Credit
- GitHub CodeQL Code Scanning
NVD description
Dynamoose is an open-source modeling tool for Amazon's DynamoDB. In Dynamoose from version 2.0.0 and before version 2.7.0 there was a prototype pollution vulnerability in the internal utility method "lib/utils/object/set.ts". This method is used throughout the codebase for various operations throughout Dynamoose. We have not seen any evidence of this vulnerability being exploited. There is no evidence this vulnerability impacts versions 1.x.x since the vulnerable method was added as part of the v2 rewrite. This vulnerability also impacts v2.x.x beta/alpha versions. Version 2.7.0 includes a patch for this vulnerability.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free