In short
- CVE-2021-22991 is a CRITICAL (CVSS 9.8) vulnerability affecting big-ip access policy manager (f5), big-ip advanced firewall manager (f5), big-ip advanced web application firewall (f5).
- Exploited in the wild: CISA added it to the KEV catalog on 18/01/2022.
- Chance of exploitation in the next 30 days (EPSS): 62.4%, higher than 99.2% of all vulnerabilities.
- Fix: update to 12.1.5.3, 13.1.3.6, 14.1.4, 15.1.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| big-ip access policy manager | ≥ 12.1.0, < 12.1.5.3≥ 13.1.0, < 13.1.3.6≥ 14.1.0, < 14.1.4≥ 15.1.0, < 15.1.2.1≥ 16.0.0, < 16.0.1.1
| 12.1.5.313.1.3.614.1.415.1.2.116.0.1.1
|
| big-ip advanced firewall manager | ≥ 12.1.0, < 12.1.5.3≥ 13.1.0, < 13.1.3.6≥ 14.1.0, < 14.1.4≥ 15.1.0, < 15.1.2.1≥ 16.0.0, < 16.0.1.1
| 12.1.5.313.1.3.614.1.415.1.2.116.0.1.1
|
| big-ip advanced web application firewall | ≥ 12.1.0, < 12.1.5.3≥ 13.1.0, < 13.1.3.6≥ 14.1.0, < 14.1.4≥ 15.1.0, < 15.1.2.1≥ 16.0.0, < 16.0.1.1
| 12.1.5.313.1.3.614.1.415.1.2.116.0.1.1
|
| big-ip analytics | ≥ 12.1.0, < 12.1.5.3
|
Description
On BIG-IP versions 16.0.x before 16.0.1.1, 15.1.x before 15.1.2.1, 14.1.x before 14.1.4, 13.1.x before 13.1.3.6, and 12.1.x before 12.1.5.3, undisclosed requests to a virtual server may be incorrectly handled by the Traffic Management Microkernel (TMM) URI normalization, which may trigger a buffer overflow, resulting in a DoS attack. In certain situations, it may theoretically allow bypass of URL based access control or remote code execution (RCE). Note: Software versions which have reached End of Software Development (EoSD) are not evaluated.
More vulnerabilities in big-ip access policy manager
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free