In short
- CVE-2021-23354 is a HIGH (CVSS 7.5) vulnerability affecting printf (adaltas), printf.
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.4% of all vulnerabilities.
- Fix: update to 0.6.1 or later.
| Package | Affected versions | Patched versions |
|---|
| printf | < 0.6.1
| 0.6.1
|
| printf npm | < 0.6.1
| 0.6.1
|
Description
The package printf before 0.6.1 are vulnerable to Regular Expression Denial of Service (ReDoS) via the regex string
/\%(?:\(([\w_.]+)\)|([1-9]\d*)\$)?([0 +\-\]*)(\*|\d+)?(\.)?(\*|\d+)?[hlL]?([\%bscdeEfFgGioOuxX])/g
in lib/printf.js. The vulnerable regular expression has cubic worst-case time complexity.
NVD description
The package printf before 0.6.1 are vulnerable to Regular Expression Denial of Service (ReDoS) via the regex string /\%(?:\(([\w_.]+)\)|([1-9]\d*)\$)?([0 +\-\]*)(\*|\d+)?(\.)?(\*|\d+)?[hlL]?([\%bscdeEfFgGioOuxX])/g in lib/printf.js. The vulnerable regular expression has cubic worst-case time complexity.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free