In short
- CVE-2021-23358 is a HIGH (CVSS 7.2) vulnerability affecting tenable.sc (tenable), underscore (underscorejs), underscore.
- Chance of exploitation in the next 30 days (EPSS): 4.2%, higher than 91.0% of all vulnerabilities.
- Fix: update to 1.13.0-2, 1.12.1 or later.
| Package | Affected versions | Patched versions |
|---|
| tenable.sc | ≤ 5.18.0
| No fix yet |
| underscore | ≥ 1.13.0-0, < 1.13.0-2≥ 1.3.2, < 1.12.1
| 1.13.0-21.12.1
|
| underscore npm | ≥ 1.3.2, < 1.12.1
| 1.12.1
|
Description
The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Execution via the template function, particularly when a variable property is passed as an argument as it is not sanitized.
NVD description
The package underscore from 1.13.0-0 and before 1.13.0-2, from 1.3.2 and before 1.12.1 are vulnerable to Arbitrary Code Injection via the template function, particularly when a variable property is passed as an argument as it is not sanitized.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free