In short
- CVE-2021-23360 is a HIGH (CVSS 8.8) vulnerability affecting killport (killport project), killport.
- Chance of exploitation in the next 30 days (EPSS): 2.3%, higher than 83.7% of all vulnerabilities.
- Fix: update to 1.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| killport | < 1.0.2
| 1.0.2
|
| killport npm | < 1.0.2
| 1.0.2
|
Description
This affects the package killport before 1.0.2. If (attacker-controlled) user input is given, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization. Running this PoC will cause the command touch success to be executed, leading to the creation of a file called success.
NVD description
This affects the package killport before 1.0.2. If (attacker-controlled) user input is given, it is possible for an attacker to execute arbitrary commands. This is due to use of the child_process exec function without input sanitization. Running this PoC will cause the command touch success to be executed, leading to the creation of a file called success.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free