In short
- CVE-2021-23389 is a CRITICAL (CVSS 9.8) vulnerability affecting total.js (totaljs), total.js.
- Chance of exploitation in the next 30 days (EPSS): 3.6%, higher than 89.5% of all vulnerabilities.
- Fix: update to 3.4.9 or later.
| Package | Affected versions | Patched versions |
|---|
| total.js | < 3.4.9
| 3.4.9
|
| total.js npm | < 3.4.9
| 3.4.9
|
Description
The package total.js before 3.4.9 are vulnerable to Arbitrary Code Execution via the U.set() and U.get() functions.
NVD description
The package total.js before 3.4.9 are vulnerable to Arbitrary Code Execution via the U.set() and U.get() functions.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free