In short
- CVE-2021-23392 is a HIGH (CVSS 7.5) vulnerability affecting locutus (locutus), locutus.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 80.1% of all vulnerabilities.
- Fix: update to 2.0.15 or later.
| Package | Affected versions | Patched versions |
|---|
| locutus | < 2.0.15
| 2.0.15
|
| locutus npm | < 2.0.15
| 2.0.15
|
Description
The package locutus before 2.0.15 is vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.
NVD description
The package locutus before 2.0.15 are vulnerable to Regular Expression Denial of Service (ReDoS) via the gopher_parsedir function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free