In short
- CVE-2021-23414 is a MEDIUM (CVSS 6.1) vulnerability affecting video.js (videojs), video.js.
- Chance of exploitation in the next 30 days (EPSS): 2.5%, higher than 85.1% of all vulnerabilities.
- Fix: update to 7.14.3 or later.
| Package | Affected versions | Patched versions |
|---|
| video.js | < 7.14.3
| 7.14.3
|
| video.js npm | < 7.14.3
| 7.14.3
|
Description
This affects the package video.js before 7.14.3.
The src attribute of track tag allows to bypass HTML escaping and execute arbitrary code.
NVD description
This affects the package video.js before 7.14.3. The src attribute of track tag allows to bypass HTML escaping and execute arbitrary code.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free