In short
- CVE-2021-23418 is a CRITICAL (CVSS 9.8) vulnerability affecting glances, glances (glances project).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 76.6% of all vulnerabilities.
- Fix: update to 3.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| glances PyPI | < 3.2.1
| 3.2.1
|
| glances | < 3.2.1
| 3.2.1
|
Description
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
NVD description
The package glances before 3.2.1 are vulnerable to XML External Entity (XXE) Injection via the use of Fault to parse untrusted XML data, which is known to be vulnerable to XML attacks.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free