In short
- CVE-2021-23422 is a HIGH (CVSS 7.8) vulnerability affecting bikeshed, bikeshed (bikeshed project).
- Chance of exploitation in the next 30 days (EPSS): 0.79%, higher than 56.4% of all vulnerabilities.
- Fix: update to 3.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| bikeshed PyPI | < 3.0.0
| 3.0.0
|
| bikeshed | < 3.0.0
| 3.0.0
|
Description
This affects the package bikeshed before 3.0.0. This can occur when an untrusted source file containing Inline Tag Command metadata is processed. When an arbitrary OS command is executed, the command output would be included in the HTML output.
NVD description
This affects the package bikeshed before 3.0.0. This can occur when an untrusted source file containing Inline Tag Command metadata is processed. When an arbitrary OS command is executed, the command output would be included in the HTML output.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free