In short
- CVE-2021-23435 is a MEDIUM (CVSS 6.1) vulnerability affecting clearance, clearance (thoughtbot).
- Chance of exploitation in the next 30 days (EPSS): 0.70%, higher than 53.4% of all vulnerabilities.
- Fix: update to 2.5.0 or later.
| Package | Affected versions | Patched versions |
|---|
| clearance RubyGems | < 2.5.0
| 2.5.0
|
| clearance | < 2.5.0
| 2.5.0
|
Description
This affects the package clearance before 2.5.0. The vulnerability can be possible when users are able to set the value of session[:return_to]. If the value used for return_to contains multiple leading slashes (/////example.com) the user ends up being redirected to the external domain that comes after the slashes (http://example.com).
NVD description
This affects the package clearance before 2.5.0. The vulnerability can be possible when users are able to set the value of session[:return_to]. If the value used for return_to contains multiple leading slashes (/////example.com) the user ends up being redirected to the external domain that comes after the slashes (http://example.com).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free