In short
- CVE-2021-23436 is a CRITICAL (CVSS 9.8) vulnerability affecting immer (immer project), immer.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.5% of all vulnerabilities.
- Fix: update to 9.0.6 or later.
| Package | Affected versions | Patched versions |
|---|
| immer | < 9.0.6
| 9.0.6
|
| immer npm | ≥ 7.0.0, < 9.0.6
| 9.0.6
|
Description
This affects the package immer before 9.0.6. A type confusion vulnerability can lead to a bypass of CVE-2020-28477 when the user-provided keys used in the path parameter are arrays. In particular, this bypass is possible because the condition (p === "__proto__" || p === "constructor") in applyPatches_ returns false if p is ['__proto__'] (or ['constructor']). The === operator (strict equality operator) returns false if the operands have different type.
NVD description
This affects the package immer before 9.0.6. A type confusion vulnerability can lead to a bypass of CVE-2020-28477 when the user-provided keys used in the path parameter are arrays. In particular, this bypass is possible because the condition (p === "__proto__" || p === "constructor") in applyPatches_ returns false if p is ['__proto__'] (or ['constructor']). The === operator (strict equality operator) returns false if the operands have different type.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free