In short
- CVE-2021-23437 is a HIGH (CVSS 7.5) vulnerability affecting pillow, pillow (python).
- Chance of exploitation in the next 30 days (EPSS): 3.2%, higher than 88.3% of all vulnerabilities.
- Fix: update to 8.3.2 or later.
| Package | Affected versions | Patched versions |
|---|
| pillow PyPI | ≥ 5.2.0, < 8.3.2< 8.3.2
| 8.3.2
|
| pillow | ≥ 5.2.0, < 8.3.2
| 8.3.2
|
Description
The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.
NVD description
The package pillow 5.2.0 and before 8.3.2 are vulnerable to Regular Expression Denial of Service (ReDoS) via the getrgb function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free