In short
- CVE-2021-23444 is a CRITICAL (CVSS 9.8) vulnerability affecting jointjs (client), jointjs.
- Chance of exploitation in the next 30 days (EPSS): 1.9%, higher than 79.3% of all vulnerabilities.
- Fix: update to 3.4.2 or later.
| Package | Affected versions | Patched versions |
|---|
| jointjs | < 3.4.2
| 3.4.2
|
| jointjs npm | < 3.4.2
| 3.4.2
|
Description
This affects the package jointjs before 3.4.2. A type confusion vulnerability can lead to a bypass of CVE-2020-28480 when the user-provided keys used in the path parameter are arrays in the setByPath function.
NVD description
This affects the package jointjs before 3.4.2. A type confusion vulnerability can lead to a bypass of CVE-2020-28480 when the user-provided keys used in the path parameter are arrays in the setByPath function.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free