In short
- CVE-2021-23509 is a CRITICAL (CVSS 9.8) vulnerability affecting json-ptr (json-ptr project), json-ptr.
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.9% of all vulnerabilities.
- Fix: update to 3.0.0 or later.
| Package | Affected versions | Patched versions |
|---|
| json-ptr | < 3.0.0
| 3.0.0
|
| json-ptr npm | < 3.0.0
| 3.0.0
|
Description
This affects the package json-ptr before 3.0.0. A type confusion vulnerability can lead to a bypass of CVE-2020-7766 when the user-provided keys used in the pointer parameter are arrays.
NVD description
This affects the package json-ptr before 3.0.0. A type confusion vulnerability can lead to a bypass of CVE-2020-7766 when the user-provided keys used in the pointer parameter are arrays.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free