In short
- CVE-2021-23555 is a CRITICAL (CVSS 9.8) vulnerability affecting vm2 (vm2 project), vm2.
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 86.8% of all vulnerabilities.
- Fix: update to 3.9.6 or later.
| Package | Affected versions | Patched versions |
|---|
| vm2 | < 3.9.6
| 3.9.6
|
| vm2 npm | < 3.9.6
| 3.9.6
|
Description
The package vm2 before 3.9.6 are vulnerable to Sandbox Bypass via direct access to host error objects generated by node internals during generation of a stacktraces, which can lead to execution of arbitrary code on the host machine.
NVD description
The package vm2 before 3.9.6 are vulnerable to Sandbox Bypass via direct access to host error objects generated by node internals during generation of a stacktraces, which can lead to execution of arbitrary code on the host machine.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free