In short
- CVE-2021-23556 is a HIGH (CVSS 8.0) vulnerability affecting guake, guake (guake-project).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 66.6% of all vulnerabilities.
- Fix: update to 3.8.5 or later.
| Package | Affected versions | Patched versions |
|---|
| guake PyPI | < 3.8.5
| 3.8.5
|
| guake | < 3.8.5
| 3.8.5
|
Description
Guake is a drop-down terminal for GNOME. The package guake before 3.8.5 is vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. Note: Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.
NVD description
The package guake before 3.8.5 are vulnerable to Exposed Dangerous Method or Function due to the exposure of execute_command and execute_command_by_uuid methods via the d-bus interface, which makes it possible for a malicious user to run an arbitrary command via the d-bus method. **Note:** Exploitation requires the user to have installed another malicious program that will be able to send dbus signals or run terminal commands.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free