In short
- CVE-2021-23568 is a CRITICAL (CVSS 9.8) vulnerability affecting extend2 (eggjs), extend2.
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.2% of all vulnerabilities.
- Fix: update to 1.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| extend2 | < 1.0.1
| 1.0.1
|
| extend2 npm | < 1.0.1
| 1.0.1
|
Description
The package extend2 before 1.0.1 are vulnerable to Prototype Pollution via the extend function due to unsafe recursive merge.
NVD description
The package extend2 before 1.0.1 are vulnerable to Prototype Pollution via the extend function due to unsafe recursive merge.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free