In short
- CVE-2021-23574 is a CRITICAL (CVSS 9.8) vulnerability affecting js-data (js-data), js-data.
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.4% of all vulnerabilities.
- Fix: update to 3.0.11 or later.
| Package | Affected versions | Patched versions |
|---|
| js-data | < 3.0.11
| 3.0.11
|
| js-data npm | ≤ 3.0.10
| No fix yet |
Description
All versions of package js-data are vulnerable to Prototype Pollution via the deepFillIn and the set functions. This is an incomplete fix of CVE-2020-28442.
NVD description
All versions of package js-data are vulnerable to Prototype Pollution via the deepFillIn and the set functions. This is an incomplete fix of [CVE-2020-28442](https://snyk.io/vuln/SNYK-JS-JSDATA-1023655).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free