In short
- CVE-2021-23937 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.wicket:wicket-core, wicket (apache).
- Chance of exploitation in the next 30 days (EPSS): 4.3%, higher than 91.1% of all vulnerabilities.
- Fix: update to 8.12.0, 9.3.0, 7.18.0 or later.
| Package | Affected versions | Patched versions |
|---|
| org.apache.wicket:wicket-core Maven | ≥ 8.0.0, < 8.12.0≥ 9.0.0, < 9.3.0< 7.18.0
| 8.12.09.3.07.18.0
|
| wicket | ≥ 6.0.0, ≤ 6.2.0≥ 7.0.0, ≤ 7.17.0≥ 8.0.0, ≤ 8.11.0≥ 9.0.0, ≤ 9.2.0
| No fix yet |
Description
A DNS proxy and possible amplification attack vulnerability in WebClientInfo of Apache Wicket allows an attacker to trigger arbitrary DNS lookups from the server when the X-Forwarded-For header is not properly sanitized. This DNS lookup can be engineered to overload an internal DNS server or to slow down request processing of the Apache Wicket application causing a possible denial of service on either the internal infrastructure or the web application itself. This issue affects Apache Wicket Apache Wicket 9.x version 9.2.0 and prior versions; Apache Wicket 8.x version 8.11.0 and prior versions; Apache Wicket 7.x version 7.17.0 and prior versions and Apache Wicket 6.x version 6.2.0 and later versions.
NVD description
A DNS proxy and possible amplification attack vulnerability in WebClientInfo of Apache Wicket allows an attacker to trigger arbitrary DNS lookups from the server when the X-Forwarded-For header is not properly sanitized. This DNS lookup can be engineered to overload an internal DNS server or to slow down request processing of the Apache Wicket application causing a possible denial of service on either the internal infrastructure or the web application itself. This issue affects Apache Wicket Apache Wicket 9.x version 9.2.0 and prior versions; Apache Wicket 8.x version 8.11.0 and prior versions; Apache Wicket 7.x version 7.17.0 and prior versions and Apache Wicket 6.x version 6.2.0 and later versions.
More vulnerabilities in org.apache.wicket:wicket-core
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free