In short
- CVE-2021-25912 is a CRITICAL (CVSS 9.8) vulnerability affecting dotty (dotty project), dotty.
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.2% of all vulnerabilities.
- Fix: update to 0.1.1 or later.
| Package | Affected versions | Patched versions |
|---|
| dotty | ≥ 0.0.1, ≤ 0.1.0
| No fix yet |
| dotty npm | < 0.1.1
| 0.1.1
|
Description
Prototype pollution vulnerability in 'dotty' before version 0.1.1 allows attackers to cause a denial of service and may lead to remote code execution.
NVD description
Prototype pollution vulnerability in 'dotty' versions 0.0.1 through 0.1.0 allows attackers to cause a denial of service and may lead to remote code execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free