In short
- CVE-2021-25913 is a CRITICAL (CVSS 9.8) vulnerability affecting set-or-get (set-or-get project), set-or-get.
- Chance of exploitation in the next 30 days (EPSS): 4.4%, higher than 91.3% of all vulnerabilities.
- Fix: update to 1.2.11 or later.
| Package | Affected versions | Patched versions |
|---|
| set-or-get | ≥ 1.0.0, ≤ 1.2.10
| No fix yet |
| set-or-get npm | ≥ 1.0.0, < 1.2.11
| 1.2.11
|
Description
Prototype pollution vulnerability in ‘set-or-get’ version 1.0.0 through 1.2.10 allows an attacker to cause a denial of service and may lead to remote code execution.
NVD description
Prototype pollution vulnerability in 'set-or-get' version 1.0.0 through 1.2.10 allows an attacker to cause a denial of service and may lead to remote code execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free