In short
- CVE-2021-25916 is a CRITICAL (CVSS 9.8) vulnerability affecting patchmerge (patchmerge project), patchmerge.
- Chance of exploitation in the next 30 days (EPSS): 3.5%, higher than 89.3% of all vulnerabilities.
- Fix: update to 1.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| patchmerge | ≥ 1.0.0, ≤ 1.0.1
| No fix yet |
| patchmerge npm | ≥ 1.0.0, < 1.0.2
| 1.0.2
|
Description
Prototype pollution vulnerability in 'patchmerge' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.
NVD description
Prototype pollution vulnerability in 'patchmerge' versions 1.0.0 through 1.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free