In short
- CVE-2021-25927 is a CRITICAL (CVSS 9.8) vulnerability affecting safe-flat (safe-flat project), safe-flat.
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.7% of all vulnerabilities.
- Fix: update to 2.0.2 or later.
| Package | Affected versions | Patched versions |
|---|
| safe-flat | ≥ 2.0.0, < 2.0.2
| 2.0.2
|
| safe-flat npm | ≥ 2.0.0, < 2.0.2
| 2.0.2
|
Description
Prototype pollution vulnerability in 'safe-flat' versions 2.0.0 through 2.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.
NVD description
Prototype pollution vulnerability in 'safe-flat' versions 2.0.0 through 2.0.1 allows an attacker to cause a denial of service and may lead to remote code execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free