In short
- CVE-2021-25953 is a CRITICAL (CVSS 9.8) vulnerability affecting putil-merge (putil-merge project), putil-merge.
- Chance of exploitation in the next 30 days (EPSS): 3.0%, higher than 87.3% of all vulnerabilities.
- Fix: update to 3.7.0 or later.
| Package | Affected versions | Patched versions |
|---|
| putil-merge | ≥ 1.0.0, ≤ 3.6.6
| No fix yet |
| putil-merge npm | ≥ 1.0.0, < 3.7.0
| 3.7.0
|
Description
Prototype pollution vulnerability in 'putil-merge' versions1.0.0 through 3.6.6 allows attacker to cause a denial of service and may lead to remote code execution.
NVD description
Prototype pollution vulnerability in 'putil-merge' versions1.0.0 through 3.6.6 allows attacker to cause a denial of service and may lead to remote code execution.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free