In short
- CVE-2021-25967 is a MEDIUM (CVSS 5.4) vulnerability affecting ckan, ckan (okfn).
- Chance of exploitation in the next 30 days (EPSS): 0.51%, higher than 43.5% of all vulnerabilities.
- Fix: update to 2.10.0, 2.9.4 or later.
| Package | Affected versions | Patched versions |
|---|
| ckan PyPI | ≥ 2.9.0, < 2.10.0≥ 2.9.0, < 2.9.4
| 2.10.02.9.4
|
| ckan | ≥ 2.9.0, ≤ 2.9.3
| No fix yet |
Description
In CKAN, versions 2.9.0 to 2.9.3 are affected by a stored XSS vulnerability via SVG file upload of users’ profile picture. This allows low privileged application users to store malicious scripts in their profile picture. These scripts are executed in a victim’s browser when they open the malicious profile picture
NVD description
In CKAN, versions 2.9.0 to 2.9.3 are affected by a stored XSS vulnerability via SVG file upload of users’ profile picture. This allows low privileged application users to store malicious scripts in their profile picture. These scripts are executed in a victim’s browser when they open the malicious profile picture
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free